SSL Certificate Generation Delays
Incident Report for Vercel
Resolved
This incident has been resolved.
Posted Dec 02, 2021 - 22:13 UTC
Monitoring
Let's Encrypt has identified and remediated the immediate problems affecting certificate issuance. We continuing to monitor.
Posted Dec 02, 2021 - 21:31 UTC
Investigating
Due to service disruption by LetsEncrypt, we are currently seeing certificate issuance delays. LetsEncrypt is investigating the root cause of this issuance disruption and are working to restore services in a timely manner. For more information, see the LetsEncrypt status: https://letsencrypt.status.io/
Posted Dec 02, 2021 - 19:42 UTC
This incident affected: Certificates.