React Router 7 function invocation errors

Incident Report for Vercel

Resolved

This incident has been resolved.
Posted May 18, 2026 - 23:52 UTC

Update

We are continuing to monitor for any further issues.
Posted May 18, 2026 - 22:19 UTC

Monitoring

A fix is rolled out for the function invocation errors affecting React Router 7 deployments. To recover, redeploy your application or use Instant Rollback to a previous deployment from the dashboard. We're continuing to monitor.
Posted May 18, 2026 - 22:16 UTC

Update

We're continuing to work on rolling out a fix. In the mean time, customers may use Instant Rollback to a previous deployment version as an immediate workaround in order to recover.
Posted May 18, 2026 - 22:11 UTC

Identified

The issue has been identified and a fix is being implemented.
Posted May 18, 2026 - 21:53 UTC

Investigating

We're investigating an issue where customers are currently experiencing application failures due to function invocation errors when using React Router 7.
Posted May 18, 2026 - 21:42 UTC
This incident affected: Edge Functions.