The Vercel API has now been fully resolved. We are continuing to monitor the Dashboard performance.
Posted Oct 20, 2025 - 23:50 UTC
Update
Builds are now being created as expected and are fully resolved.
Posted Oct 20, 2025 - 23:27 UTC
Update
We continue to work on resolving the Dashboard and API failures.
Posted Oct 20, 2025 - 22:20 UTC
Update
We have processed a backlog of builds but we are still observing errors initiating new builds. We have determined the root cause and are working on a fix.
Posted Oct 20, 2025 - 22:08 UTC
Update
We have identified the root cause of build failures and are working on a fix.
Posted Oct 20, 2025 - 21:52 UTC
Identified
We have identified the root cause of the Dashboard degradation, and a fix is being worked on.
Posted Oct 20, 2025 - 21:12 UTC
Investigating
Increased Vercel dashboard failures, API failures, and deployment failures. CDN requests are functioning as expected.
Posted Oct 20, 2025 - 20:00 UTC
This incident affected: Dashboard (Dashboard), Build & Deploy (Builds), and API.