Issue with DNS Record Propagation

Incident Report for Vercel

Resolved

The incident has been resolved.
Posted Mar 09, 2025 - 15:33 UTC

Update

We are continuing to monitor for any further issues.
Posted Mar 09, 2025 - 15:25 UTC

Monitoring

We have pushed a fix and DNS record should be propagated now.
Posted Mar 09, 2025 - 15:16 UTC

Update

We are continuing to work on a fix for this issue.
Posted Mar 09, 2025 - 15:04 UTC

Identified

We are currently experiencing issue that prevent the creation of new DNS records for new domains. Thanks for your patience and understanding.
Posted Mar 09, 2025 - 14:38 UTC
This incident affected: DNS and Domain Registration.