Increased deployment failures

Incident Report for Vercel

Resolved

This incident has been resolved. Builds have recovered.
Posted Sep 01, 2026 - 20:58 UTC

Update

We are continuing to monitor for any further issues.
Posted Sep 01, 2026 - 20:49 UTC

Monitoring

We are seeing recovery in Builds and are continuing to monitor.
Posted Sep 01, 2026 - 20:45 UTC

Identified

We have identified the issue and are working on a fix. We are seeing recovery as the fix is deployed. We will provide additional updates as they become available.
Posted Sep 01, 2026 - 20:37 UTC

Update

We are actively working to fix an issue causing some deployments that use IAD1 Function regions or Routing Middleware to fail. We will provide additional updates as they become available.
Posted Sep 01, 2026 - 20:27 UTC

Investigating

We've identified an issue where some deployments that use IAD1 Function regions or Routing Middleware are failing. We are investigating and will provide more information as it becomes available.
Posted Sep 01, 2026 - 19:59 UTC
This incident affected: Build & Deploy (Builds).