Queued builds for some customers

Incident Report for Vercel

Resolved

This incident has been resolved.
Posted May 08, 2022 - 21:33 UTC

Monitoring

Builds are no longer experiencing elevated queuing times and the queue has been fully processed.
Posted May 08, 2022 - 21:18 UTC

Identified

New builds are working as expected and past queued builds are being processed.
Posted May 08, 2022 - 20:55 UTC

Investigating

We are currently investigating elevated queued builds for for a portion of our customers.
Posted May 08, 2022 - 20:24 UTC
This incident affected: Build & Deploy (Builds).