Delayed Dashboard Data Across Multiple Services

Incident Report for Vercel

Resolved

This incident has been resolved.
Posted Jan 26, 2026 - 17:57 UTC

Update

A fix is currently being rolled out. Most customers should now be seeing recovery, and we expect this incident to be fully resolved shortly.
Posted Jan 26, 2026 - 17:35 UTC

Update

We are continuing to work on a fix for this issue.
Posted Jan 26, 2026 - 16:04 UTC

Identified

The issue has been identified and a fix is being implemented.
Posted Jan 26, 2026 - 15:25 UTC

Investigating

We are currently investigating reports of delayed metrics for Observability, Speed Insights, Web Analytics, Usage, and Audit Logs. We will share updates as they become available.
Posted Jan 26, 2026 - 14:50 UTC
This incident affected: Dashboard (Dashboard) and Speed Insights, Web Analytics.