GitLab integration authentication and deployment issues

Incident Report for Vercel

Resolved

This incident has been resolved. The issue originated from a disruption on GitLab’s side. For more information, please refer to their incident report: https://gitlab.com/gitlab-com/gl-infra/production/-/issues/20290
Posted Aug 01, 2025 - 08:49 UTC

Monitoring

The errors with authenticating and deploying through GitLab have been reduced. We are continuing to monitor.
Posted Aug 01, 2025 - 07:11 UTC

Investigating

We're currently investigating the issue affecting GitLab authentication and deployment failures.
Posted Aug 01, 2025 - 05:27 UTC
This incident affected: Build & Deploy (Builds).