Some Enhanced Build Machines are queued

Incident Report for Vercel

Resolved

The issue has now been fully resolved. From 12:15 UTC - 14:57 UTC, a portion of deployments on Enhanced Build Machines were delayed in a "Queued" state. No deployments were lost and all deployments are now building as expected.
Posted Apr 03, 2025 - 15:31 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Apr 03, 2025 - 15:08 UTC

Identified

The issue has been identified and a fix is being implemented.
Posted Apr 03, 2025 - 15:00 UTC
This incident affected: Build & Deploy (Builds).