SSL Certificate Generation Delays
Incident Report for Vercel
Resolved
All systems normal.
Posted Oct 12, 2021 - 01:01 UTC
Identified
Let's Encrypt has identified the issue and is preparing to deploy a fix → https://letsencrypt.status.io/. We will provide a further update once available.
Posted Oct 12, 2021 - 00:27 UTC
Investigating
Due to service disruption by Let's Encrypt, we are currently unable to issue new certificates. For more information, see the Let's Encrypt status → https://letsencrypt.status.io/. We will provide a further update once available.
Posted Oct 11, 2021 - 22:47 UTC
This incident affected: Certificates.