Elevated errors creating deployments with integrations and increased delays in delivering webhooks

Incident Report for Vercel

Resolved

This incident has been resolved.
Posted Apr 01, 2026 - 22:17 UTC

Monitoring

A fix has been implemented and we are monitoring the results. Webhook events are being delivered normally, and deployments with integrations are building successfully.
Posted Apr 01, 2026 - 21:57 UTC

Identified

We have identified an issue causing elevated latency and errors with delivering webhooks and creating deployments that use integrations. We are working on a fix for this issue and will provide further updates as soon as they become available.
Posted Apr 01, 2026 - 20:48 UTC
This incident affected: Build & Deploy (Builds).