Delays Issuing New SSL Certificates
Incident Report for Vercel
Resolved
This incident has been resolved.
Posted Nov 26, 2024 - 12:00 UTC
Monitoring
A fix has been implemented and we are monitoring the backlog of delayed certificates, which is decreasing.
Once the backlog of the affected domains is clear we will mark the incident as resolved
Posted Nov 26, 2024 - 11:39 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Nov 26, 2024 - 11:24 UTC
Investigating
We are currently investigating an issue causing new SSL certificates to be delayed.
Posted Nov 26, 2024 - 11:12 UTC
This incident affected: SSL Certificates.