Delays Processing Builds

Incident Report for Vercel

Resolved

This incident has been resolved.
Posted May 08, 2026 - 16:41 UTC

Monitoring

We have applied a fix and are observing recovery across all builds. We'll provide additional updates as-needed.
Posted May 08, 2026 - 16:33 UTC

Identified

We've identified an issue where some customers may experience delays in builds starting and/or builds stuck in an initializing state. We are applying a fix and will provide additional updates as they become available.
Posted May 08, 2026 - 16:30 UTC
This incident affected: Build & Deploy (Builds).