Pro usage within allocation is incorrectly being reported as an on-demand charge

Incident Report for Vercel

Resolved

This incident has been resolved.
Posted Jul 02, 2025 - 19:15 UTC

Identified

The issue has been identified and a fix is being implemented.
Posted Jul 02, 2025 - 15:09 UTC

Investigating

Pro usage within the allocation for regionally priced products is currently being displayed as an on-demand charge as part of our recent iteration on the Usage dashboard. This is a display issue only. You won’t be charged for usage within your allocation. We’re actively working to fix this.
Posted Jul 02, 2025 - 15:03 UTC
This incident affected: Dashboard (Dashboard).