Deployment stuck in initializing state

Incident Report for Vercel

Resolved

This incident has been resolved.
Posted Sep 18, 2026 - 22:31 UTC

Monitoring

We have identified an issue causing deployments to get stuck in an initialized state, applied a fix, and are seeing signs of recovery for new deployments. We are continuing to monitor.
Posted Sep 18, 2026 - 22:14 UTC

Investigating

We are currently investigating an issue causing an elevated rate of deployments getting stuck in an initializing state. We will provide additional updates as they become available.
Posted Sep 18, 2026 - 21:36 UTC
This incident affected: Build & Deploy (Builds).