We are investigating intermittent errors on the Vercel dashboard.
Posted Oct 21, 2025 - 01:47 UTC
Update
We have identified the root cause of the Logs and Log Drains issue and we are rolling out a fix.
Posted Oct 21, 2025 - 00:56 UTC
Update
We are investigating errors affecting runtime Logs and Log Drains.
Posted Oct 21, 2025 - 00:32 UTC
Update
Edge Config issues are now resolved.
Posted Oct 21, 2025 - 00:08 UTC
Update
Domain Registrations issues are now resolved.
Posted Oct 20, 2025 - 23:14 UTC
Update
A fix has been implemented for Edge Config, and we are monitoring the result.
Posted Oct 20, 2025 - 21:57 UTC
Update
A fix has been implemented for Domain Registrations, and we are monitoring the result.
Posted Oct 20, 2025 - 21:50 UTC
Update
We have identified Domain Registration failures and are working to restore service.
Posted Oct 20, 2025 - 21:34 UTC
Update
We have identified degraded performance with Edge Config storage and are working to restore service.
Posted Oct 20, 2025 - 20:24 UTC
Update
New deployments using Routing Middleware or Vercel Functions in the IAD1 region may fail to deploy. Traffic is still successfully being rerouted away from IAD1, which may result in increased latency. We are seeing full recovery of Edge Function and Middleware invocation errors in our IAD1 region. We are investigating an intermittent elevation of Cron Jobs not being executed. Historical data for Speed Insights and Web Analytics is currently being backfilled.
Posted Oct 20, 2025 - 18:45 UTC
Update
New deployments using Routing Middleware or Vercel Functions in the IAD1 region may fail to deploy. Traffic is still successfully being rerouted away from IAD1, which may result in increased latency. We are seeing full recovery of Edge Function and Middleware invocation errors in our IAD1 region. We are investigating an intermittent elevation of Cron Jobs not being executed. Historical data for Speed Insights and Web Analytics is currently being backfilled.
Posted Oct 20, 2025 - 18:40 UTC
Update
We are seeing recovery across Edge Functions and Middleware invocation errors in our IAD1 region. Historical data for Speed Insights and Web Analytics is currently being backfilled. Deployment creation for customers using Secure Compute or Static IPs are still impacted. Traffic is still successfully being rerouted away from iad1, which may result in increased latency.
Posted Oct 20, 2025 - 18:06 UTC
Update
We are investigating an intermittent elevation of Edge Function and Middleware invocation errors in our IAD1 region. Impacted customers may encounter errors with the code INTERNAL_FUNCTION_INVOCATION_FAILED. Historical data for Speed Insights and Web Analytics is currently being backfilled. Deployment creation for customers using Secure Compute or Static IPs are still impacted. Traffic is still successfully being rerouted away from iad1, which may result in increased latency.
Posted Oct 20, 2025 - 17:36 UTC
Update
Historical data for Speed Insights and Web Analytics is currently being backfilled. Deployment creation for customers not using Secure Compute or Static IPs has been fully restored. Traffic is still successfully being rerouted away from IAD1, which may result in increased latency.
Posted Oct 20, 2025 - 16:12 UTC
Update
We are currently investigating reports of delayed data for Speed Insights and Web Analytics.
Posted Oct 20, 2025 - 15:38 UTC
Update
We are currently investigating reports of delayed data for Speed Insights and Web Analytics.
Posted Oct 20, 2025 - 15:32 UTC
Update
We are seeing recovery across deployment creation using Routing Middleware and Functions in IAD1.
CDN traffic in IAD1 continues to be rerouted as we work toward full recovery. During this period, users may experience increased latency.
Posted Oct 20, 2025 - 12:17 UTC
Update
We are continuing to work on a fix for this issue.
Posted Oct 20, 2025 - 10:28 UTC
Update
We are continuing to work on a fix for this issue.
Posted Oct 20, 2025 - 10:27 UTC
Update
New deployments using Routing Middleware, or Vercel Functions with iad1 region may still be failing. We are continuing to investigate this issue.
Posted Oct 20, 2025 - 10:16 UTC
Update
We are seeing recovery across services and CDN traffic is healthy.
Posted Oct 20, 2025 - 08:45 UTC
Identified
Multiple services are affected. We have re-routed CDN traffic from iad1 to a healthy region and are working on managing impact by component. Builds have also been rerouted.
Posted Oct 20, 2025 - 08:03 UTC
Update
We are continuing to investigate this issue.
Posted Oct 20, 2025 - 07:50 UTC
Update
We are continuing to investigate this issue.
Posted Oct 20, 2025 - 07:40 UTC
Update
We are continuing to investigate this issue.
Posted Oct 20, 2025 - 07:33 UTC
Update
We are continuing to investigate this issue.
Posted Oct 20, 2025 - 07:33 UTC
Investigating
We are currently investigating this issue.
Posted Oct 20, 2025 - 07:30 UTC
This incident affects: Dashboard (Dashboard), Build & Deploy (Builds), Storage (Edge Config), Cron Jobs, Domain Registration, Edge Functions, Edge Middleware, Logs, Log Drains, Speed Insights, Web Analytics, and Edge Network (IAD1 - Washington DC, USA).