Elevated errors (SIGSEGV) for Vercel Functions running Node.js 20 in cle1 and dub1 regions

Incident Report for Vercel

Resolved

This incident has been resolved.
Posted Apr 02, 2026 - 18:53 UTC

Monitoring

The root cause has been identified, a fix has been rolled out, and we are actively monitoring. Newly deployed Vercel Functions on Node.js 20 in cle1 and dub1 no longer terminate with SIGSEGV. We recommend redeploying affected Vercel Functions if you are still seeing issues.
Posted Apr 02, 2026 - 18:09 UTC

Update

We are continuing to investigate increased rates of Vercel Functions running on Node.js 20 terminating with SIGSEGV in Vercel's cle1 and dub1 regions. Other regions are unaffected. We recommend redeploying affected Vercel Functions or upgrading them to either Node js 22 or 24.
Posted Apr 02, 2026 - 16:13 UTC

Investigating

We are currently investigating increased rates of Vercel Functions running on Node.js 20 terminating with SIGSEGV. We recommend redeploying affected Vercel Functions or upgrading them to either Node.js 22 or 24.
Posted Apr 02, 2026 - 14:10 UTC
This incident affected: Serverless Functions.