Some domain purchases are failing

Incident Report for Vercel

Resolved

After monitoring, we do not see the issue persisting. This incident is resolved.
Posted Jan 23, 2026 - 04:28 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jan 23, 2026 - 03:49 UTC

Identified

The issue has been identified and a fix is being implemented.
Posted Jan 23, 2026 - 03:48 UTC

Investigating

We are currently investigating an issue where some domain purchases are failing.
Posted Jan 23, 2026 - 03:35 UTC
This incident affected: Domain Registration.