Delays Loading Observability, Usage, Analytics, and Speed Insights Data

Incident Report for Vercel

Resolved

This incident has been resolved.
Posted Mar 03, 2026 - 21:10 UTC

Monitoring

A fix has been implemented and we are seeing recovery for data loading and ingestion across services. We are continuing to monitor and will provide additional updates as they become available.
Posted Mar 03, 2026 - 19:14 UTC

Investigating

Dashboard pages that use Observability data, including Observability, Speed Insights, Web Analytics, Usage, Firewall, and Activity, are experiencing delays while loading data. These pages are also experiencing delays ingesting new data. We are investigating this issue and will provide additional updates as they become available.
Posted Mar 03, 2026 - 17:10 UTC
This incident affected: Dashboard (Dashboard) and Speed Insights, Web Analytics.