Elevated INTERNAL_UNEXPECTED_ERROR error rates for some deployments

Incident Report for Vercel

Resolved

This incident has been resolved.
Posted Apr 02, 2026 - 23:09 UTC

Monitoring

The fix has been rolled out and we are monitoring the results. If you are still seeing issues, we recommend redeploying or performing an instant rollback to fix the issue.
Posted Apr 02, 2026 - 20:02 UTC

Identified

We have identified the issue and are rolling out a fix. Deployments created between 16:10 to 19:12 UTC may be affected. If you are still seeing issues, we recommend redeploying or performing an instant rollback to fix the issue.
Posted Apr 02, 2026 - 19:26 UTC

Investigating

We are investigating reports of elevated INTERNAL_UNEXPECTED_ERROR responses affecting some customer deployments. We will provide updates as we learn more.
Posted Apr 02, 2026 - 18:39 UTC
This incident affected: Build & Deploy (Builds).