Increased edge middleware and edge functions failures
Incident Report for Vercel
Resolved
There was an increase in Edge Middleware and Edge Functions failures between 2024-07-24 18:53 - 2024-07-24 19:53 PM UTC.

1. Between 2024-07-24 19:13 and 2024-07-24 19:27 PM UTC, requests served from the cpt1 (Cape Town, South Africa) Vercel region may have seen 400 errors on URLs that use Edge Middleware or Edge Functions.

2. Between 2024-07-24 18:53 - 2024-07-24 19:53 PM UTC, Edge Functions specifying the execution region in the function code may have seen 400 errors in any regions.

We've identified the root cause and have rolled out a fix.
Posted Jul 24, 2024 - 20:03 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jul 24, 2024 - 19:27 UTC
Investigating
We are currently investigating the edge function and middleware failures in CPT1 and will provide updates as they are received.
Posted Jul 24, 2024 - 19:21 UTC
This incident affected: Edge Network (CPT1 - Cape Town, South Africa) and Edge Functions, Edge Middleware.