Investigating DNS timeouts on Google Console

Incident Report for Vercel

Resolved

This incident has been resolved. We will continue to support any reports that come in regarding this.
Posted May 26, 2023 - 18:36 UTC

Investigating

We are observing degraded DNS performance with our upstream provider. We are working closely with them to resolve the issue as soon as possible.
Posted May 25, 2023 - 18:44 UTC
This incident affected: DNS.