Increased latency and connection errors in multiple regions

Incident Report for Vercel

Resolved

This incident has been resolved.
Posted Mar 11, 2025 - 07:25 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Mar 11, 2025 - 07:12 UTC

Identified

The issue has been identified and a fix is being implemented.
Posted Mar 11, 2025 - 06:51 UTC

Update

Issue is isolated to the following regions: iad1, sfo1, sin1, fra1, cle1, hnd1
We are continuing to investigate.
Posted Mar 11, 2025 - 06:32 UTC

Investigating

We are currently investigating this issue and will provide additional updates as new information is revealed.
Posted Mar 11, 2025 - 06:25 UTC
This incident affected: Edge Network (CLE1 - Cleveland, East US, FRA1 - Frankfurt, Germany, Europe, HND1 - Tokyo, Japan, IAD1 - Washington DC, USA, SFO1 - San Francisco, CA, USA, SIN1 - Singapore).