Elevated Errors on Middleware Invocations

Incident Report for Vercel

Resolved

This incident has been resolved.
Posted Mar 06, 2026 - 21:38 UTC

Monitoring

A fix has been applied and we are seeing recovery for affected deployments. We are continuing to monitor.
Posted Mar 06, 2026 - 21:20 UTC

Update

We are applying a fix for the deployments experiencing elevated errors.

We continue to recommend redeploying if you are seeing errors on deployments created between 11:20 UTC and 15:14 UTC. Deployments created outside of this window are unaffected and no action is required. Additionally, deployments with middleware on the Node runtime are unaffected.
Posted Mar 06, 2026 - 19:18 UTC

Identified

Some deployments created between 11:20 UTC and 15:14 UTC with Edge Middleware may be seeing elevated errors. Deployments created outside of this time window are unaffected. If you are experiencing issues, we recommend redeploying.
Posted Mar 06, 2026 - 15:25 UTC
This incident affected: Edge Middleware.