Degraded Support Case Submission

Incident Report for Vercel

Resolved

This incident has been resolved.
Posted Mar 31, 2026 - 13:29 UTC

Update

Support case submission has been confirmed to be functioning normally. We will share updates as they become available.
Posted Mar 31, 2026 - 13:16 UTC

Monitoring

A fix has been implemented and we are monitoring the results. We will share updates as they become available.
Posted Mar 31, 2026 - 13:16 UTC

Investigating

We are currently investigating reports of elevated errors when submitting support cases. Some customers may experience timeouts when creating support tickets. We will share updates as they become available.
Posted Mar 31, 2026 - 13:10 UTC
This incident affected: Dashboard (Support Center).