Blob has fully recovered. This incident has been resolved.
Posted Sep 04, 2026 - 20:27 UTC
Update
Elevated latency has recovered for VCR and Sandbox. We are continuing to investigate elevated latency affecting Blob and will provide another update shortly.
Posted Sep 04, 2026 - 20:19 UTC
Monitoring
The fix has been rolled out and we are seeing signs of recovery.
Posted Sep 04, 2026 - 20:05 UTC
Update
The fix is currently being rolled out. We'll provide another update once the rollout is complete and we're beginning to see signs of recovery.
Posted Sep 04, 2026 - 19:55 UTC
Update
We are continuing to work on a fix for this issue.
Posted Sep 04, 2026 - 19:33 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Sep 04, 2026 - 19:33 UTC
Investigating
We've identified an issue where some customers may experience increased latency for API requests to VCR, Blob, and Sandbox. We are currently investigating this issue. We will provide additional updates as they become available.
Posted Sep 04, 2026 - 19:11 UTC
This incident affected: Storage (Blob) and Sandbox.