Degraded Domain Search in Vercel Dashboard

Incident Report for Vercel

Resolved

This incident has been resolved.
Posted Jun 23, 2026 - 23:34 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jun 23, 2026 - 23:28 UTC

Identified

The issue has been identified and a fix is being implemented.
Posted Jun 23, 2026 - 23:26 UTC

Investigating

We're investigating an issue preventing customers from searching for and purchasing domains in the Vercel Dashboard.
Posted Jun 23, 2026 - 23:24 UTC
This incident affected: Domain Registration.