Degraded performance on CDN, Dashboard, Functions in Washington, Cleveland (iad1, cle1)

Incident Report for Vercel

Resolved

This incident has been resolved.
Posted Jul 02, 2026 - 16:46 UTC

Monitoring

A fix has been implemented and we are observing recovery across CDN, Dashboard, & Functions in Washington, Cleveland (iad1, cle1). We are continuing to monitor.
Posted Jul 02, 2026 - 16:39 UTC

Identified

The issue has been identified and a fix is being implemented.
Posted Jul 02, 2026 - 16:33 UTC

Investigating

We are investigating an issue causing degraded performance across CDN, Dashboard, & Functions in Washington, Cleveland (iad1, cle1). We'll provide additional updates as they become available.
Posted Jul 02, 2026 - 16:31 UTC
This incident affected: Dashboard (Dashboard), CDN (CLE1 - Cleveland, East US, IAD1 - Washington DC, USA), and Functions.