Elevated queue times for deployments on the Hobby plan

Incident Report for Vercel

Resolved

This incident has been resolved.
Posted Apr 07, 2026 - 18:56 UTC

Update

A fix has been rolled out, and we are monitoring the results. Queued deployments are being processed and new deployments are building normally now.
Posted Apr 07, 2026 - 18:27 UTC

Identified

We have identified an issue causing elevated queue times for deployments on the Hobby plan. We are investigating a fix and will share more updates as soon as we have more information.
Posted Apr 07, 2026 - 18:06 UTC
This incident affected: Build & Deploy (Builds).