Partial disruption of Observability, Analytics, Firewall, and Usage in dashboard

Incident Report for Vercel

Resolved

The incident has been resolved.
Posted Jun 16, 2026 - 15:39 UTC

Monitoring

The team has deployed a fix for timeouts and failed requests related to Observability, Web Analytics, Speed Analytics, Firewall, and Usage in dashboard. We are continuing to monitor.
Posted Jun 16, 2026 - 15:26 UTC

Identified

The team has identified the source of the issue and is preparing a fix for timeouts and failed requests related to Observability, Web Analytics, Speed Analytics, Firewall, and Usage in dashboard.
Posted Jun 16, 2026 - 15:16 UTC

Update

We are continuing to investigate partial disruption to Observability, Web Analytics, Speed Analytics, Firewall, and Usage in dashboard. We are also investigating delayed usage alerts.
Posted Jun 16, 2026 - 14:45 UTC

Investigating

We are investigating a partial disruption to Observability, Web Analytics, Speed Analytics and Firewall features.
Posted Jun 16, 2026 - 13:39 UTC
This incident affected: Dashboard (Dashboard), Observability (Observability, Speed Insights, Web Analytics), and Firewall.