Intermittent failures for builds using Secure Compute or Static IPs

Incident Report for Vercel

Resolved

This incident has been resolved.
Posted Oct 29, 2025 - 00:51 UTC

Update

We are continuing to monitor for any further issues.
Posted Oct 29, 2025 - 00:51 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Oct 29, 2025 - 00:22 UTC

Update

We're seeing recovery for this issue. Users can redeploy the affected deployments.
Posted Oct 28, 2025 - 23:50 UTC

Identified

New deployments that use Secure Compute or Static IPs are currently experiencing intermittent failures. We've identified the issue and are working to resolve this. Users will need to redeploy affected deployments after the issue is resolved. Existing deployments are not affected.
Posted Oct 28, 2025 - 23:15 UTC
This incident affected: Build & Deploy (Builds).