Team Invites Not Working

Incident Report for Vercel

Resolved

This incident has been resolved.
Posted Aug 17, 2022 - 19:48 UTC

Investigating

We are investigating reports of users being unable to accept invites to join teams.
Posted Aug 17, 2022 - 19:19 UTC