Intermittent deployment failures and elevated dashboard latency

Incident Report for Vercel

Resolved

This incident has been resolved.
Posted Aug 12, 2025 - 17:43 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Aug 12, 2025 - 17:32 UTC

Investigating

We are currently investigating reports of deployment failures and elevated latency in the Vercel dashboard due to an API issue. This issue does not affect production deployments or live traffic.
Posted Aug 12, 2025 - 17:24 UTC
This incident affected: Dashboard (Dashboard).