Builds and Deployments are Currently in a Queued State

Incident Report for Vercel

Resolved

This incident has been resolved.
Posted Nov 11, 2025 - 19:25 UTC

Identified

We have identified the issue and are working to process the backlog of queued builds.
Posted Nov 11, 2025 - 19:13 UTC

Investigating

All builds are stuck in a queued state. Our team is currently investigating this issue. Live deployments are not affected.
Posted Nov 11, 2025 - 18:43 UTC
This incident affected: Build & Deploy (Builds).