Elevated Domains Errors

Incident Report for Vercel

Resolved

This incident has been resolved.
Posted Apr 29, 2026 - 16:42 UTC

Monitoring

A fix has been applied and we are seeing signs of recovery across domains operations. We are continuing to monitor and will provide additional updates as needed.
Posted Apr 29, 2026 - 16:20 UTC

Investigating

We are investigating an issue causing elevated error rates across domains operations, including renewals, nameserver changes, search, and checkout. We will provide additional updates as they become available.
Posted Apr 29, 2026 - 15:28 UTC
This incident affected: Dashboard (Dashboard) and Domain Registration.