Service Disruption: Billing, Team Management, and Plan Upgrades

Incident Report for Vercel

Resolved

This incident has been resolved.
Posted Jun 17, 2025 - 16:58 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jun 17, 2025 - 16:17 UTC

Investigating

We're currently experiencing issues with an upstream provider affecting usage and invoice viewing, team creation, plan upgrades, product purchases, and access to the v0 plan. We're working to resolve this as quickly as possible.
Posted Jun 17, 2025 - 15:57 UTC
This incident affected: Dashboard (Dashboard).