Increase in Workflow runs stuck in pending, failed

Incident Report for Vercel

Update

We are continuing to work on recovering affected workflow runs that may be stuck in a pending state or have reached a failed state.

New workflow runs are not impacted.
Posted Jul 01, 2026 - 17:49 UTC

Identified

We've identified an issue where some workflow runs created between June 30 at 22:24 UTC and July 1 at 16:08 UTC may be stuck in a pending state or have reached a failed state.

New workflow runs are not impacted. We are working on a fix for runs stuck in a pending state and will provide additional updates as they become available.
Posted Jul 01, 2026 - 16:57 UTC
This incident affects: Workflow.