Elevated errors on Vercel Dashboard and API endpoints

Incident Report for Vercel

Resolved

This incident has been resolved.
Posted Apr 20, 2026 - 20:56 UTC

Monitoring

A fix has been implemented and we are observing recovery in error rates across the Vercel Dashboard and API endpoints. We will continue to monitor and share any additional updates as they become available.
Posted Apr 20, 2026 - 20:33 UTC

Identified

We have identified an issue causing elevated error rates on the Vercel Dashboard and API endpoints. Some users may experience an issue creating new deployments, but existing deployments are not impacted. We will share more updates as they become available.
Posted Apr 20, 2026 - 19:40 UTC
This incident affected: Dashboard (Dashboard), Build & Deploy (Builds), and API.