SSL certificate issues causing SSL/TLS errors

Incident Report for Vercel

Resolved

This incident has been resolved.
Posted Feb 26, 2025 - 06:26 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Feb 26, 2025 - 06:00 UTC

Identified

We have identified the root cause of this issue and are actively working on a fix.
Posted Feb 26, 2025 - 05:46 UTC

Investigating

We are currently investigating an issue with SSL certificates that may be causing SSL/TLS errors for visitors to sites hosted on Vercel.

We are actively working to resolve this matter and will provide further updates as soon as they become available.
Posted Feb 26, 2025 - 05:31 UTC
This incident affected: SSL Certificates.