Vercel Dashboard not accessible

Incident Report for Vercel

Resolved

This incident has been resolved.
Posted Jun 09, 2025 - 19:18 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jun 09, 2025 - 18:54 UTC

Identified

At this time, Vercel Dashboard is inaccessible for all users. We have identified the root cause and are implementing a fix.
Posted Jun 09, 2025 - 18:43 UTC
This incident affected: Dashboard (Dashboard).