Partial disruption of Observability, Analytics, Firewall, Usage, and Login in Dashboard

Incident Report for Vercel

Resolved

Services have recovered. We are still working to ingest missing observability data during this period.
Posted Aug 17, 2026 - 21:25 UTC

Update

Services have recovered. We are still working to ingest missing observability data during this period.
Posted Aug 17, 2026 - 20:13 UTC

Update

Login with TOTP has completely recovered. We are still working to ingest missing observability data during this period. We will share more information as it becomes available.
Posted Aug 17, 2026 - 17:51 UTC

Update

We are continuing to monitor for any further issues.
Posted Aug 17, 2026 - 16:46 UTC

Monitoring

We have implemented a fix for the disruption, and services have started to recover. We will share more information as it becomes available.
Posted Aug 17, 2026 - 16:44 UTC

Update

We are also investigating an issue where some customers may be unable to sign in to Dashboard with time-based one-time passwords (TOTP). We will share updates as they become available.
Posted Aug 17, 2026 - 16:06 UTC

Update

We are continuing to investigate this issue. We will share updates as they become available.
Posted Aug 17, 2026 - 15:09 UTC

Investigating

We are investigating a partial disruption to Observability, Web Analytics, Speed Insights, Firewall, and Usage in Dashboard. We will share updates as they become available.
Posted Aug 17, 2026 - 14:30 UTC
This incident affected: Dashboard (Dashboard), Observability (Observability, Speed Insights, Web Analytics), and Firewall.