DNS record updates are delayed for domains using Vercel Nameservers

Incident Report for Vercel

Resolved

This incident has been resolved.
Posted Sep 17, 2025 - 14:30 UTC

Update

This incident has been resolved, and we continue to monitor our systems closely.

SSL certificates are still being processed for domains recently acquired through Vercel or that switched to Vercel's Nameservers recently.
Posted Sep 17, 2025 - 10:00 UTC

Monitoring

This incident has been resolved, and we continue to monitor our systems closely.
Posted Sep 17, 2025 - 09:57 UTC

Update

The issue has been addressed in a few DNS regions. We are working to resolve this issue fully as soon as possible.
Posted Sep 17, 2025 - 05:07 UTC

Update

We are closely working with our partners to address this issue as soon as possible.
Posted Sep 16, 2025 - 22:52 UTC

Identified

The issue has been identified, and a fix is being implemented.
Posted Sep 16, 2025 - 19:22 UTC

Investigating

Vercel is experiencing issues updating DNS records for new domains acquired through our platform, domains that recently switched to Vercel's Nameservers, and new DNS records added to domains that are already using Vercel's Nameservers.
Posted Sep 16, 2025 - 19:02 UTC
This incident affected: DNS.