Intermittent errors affecting APIs and new builds

Incident Report for Vercel

Resolved

The issue has been fully mitigated, and this incident has been resolved. No action is needed for customers with queued builds.
Posted Oct 30, 2025 - 18:00 UTC

Identified

We have identified the root cause of the issue and have deployed a fix.
Posted Oct 30, 2025 - 17:34 UTC

Investigating

We are investigating an issue causing intermittent errors from our public APIs and impacting new builds. Existing deployments are not impacted.
Posted Oct 30, 2025 - 17:15 UTC
This incident affected: Build & Deploy (Builds) and API.