Support cases cannot be submitted

Incident Report for Vercel

Resolved

The incident is resolved and support cases can be submitted again.
Posted May 18, 2026 - 15:41 UTC

Monitoring

We have implemented a fix. New support cases can be created. We continue to monitor.
Posted May 18, 2026 - 15:17 UTC

Investigating

We are investigating an issue where support cannot be submitted through the dashboard.
Posted May 18, 2026 - 15:00 UTC
This incident affected: Dashboard (Support Chat).