Elevated Errors on Vercel Dashboard (Project Overview Page)

Incident Report for Vercel

Resolved

This incident has been resolved.

We've rolled back a bad release to resolve the issue. Customers were unable to access the project overview page between 04:13 and 05:00 AM UTC.
Posted May 27, 2026 - 05:02 UTC

Investigating

We are currently investigating this issue.
Posted May 27, 2026 - 04:50 UTC
This incident affected: Dashboard (Dashboard).