Deployments are failing for customers using Static IPs in Dubai region (dxb1)

Incident Report for Vercel

Resolved

A fix has been implemented and new deployments are no longer failing.
Posted Mar 02, 2026 - 00:22 UTC

Identified

Deployments for customers that use Static IPs are failing when deploying functions to the Dubai region. Customers can remove the Dubai region from the Static IPs configuration to avoid deployment failures. Our team is actively investigating the issue. Deployments to other regions are not affected.
Posted Mar 01, 2026 - 21:17 UTC
This incident affected: Build & Deploy (Builds).