Elevated Build Queue Times
Incident Report for Vercel
Resolved
Deployments appearing as “QUEUED” have recovered, and all new deployments are now working as expected. The incident has been resolved.
Posted Feb 19, 2024 - 19:56 UTC
Identified
The issue has been identified and a fix is in the works. To note: this issue is only present on builds using Node 20. Builds using Node 18 and below are functioning normally.
Posted Feb 19, 2024 - 19:13 UTC
Investigating
We are currently investigating reports of queued builds. We will share updates as they become available.
Posted Feb 19, 2024 - 19:01 UTC
This incident affected: Build & Deploy (Builds).