Increased TLS handshake latency

Incident Report for Vercel

Resolved

This incident has been resolved.
Posted Nov 28, 2023 - 09:49 UTC

Monitoring

We started seeing recovery in all regions at 7:50 UTC and we are monitoring the results.
Posted Nov 28, 2023 - 08:17 UTC

Investigating

At 7:19 UTC, we started to see an increase in TLS handshake latency and associated error rates. We are currently investigating this issue.
Posted Nov 28, 2023 - 08:06 UTC
This incident affected: Edge Network (ARN1 - Stockholm, Sweden, BOM1 - Mumbai, India, CDG1 - Paris, France, Europe, CLE1 - Cleveland, East US, CPT1 - Cape Town, South Africa, DUB1 - Dublin, Ireland, FRA1 - Frankfurt, Germany, Europe, GRU1 - São Paulo, Brazil, HKG1 - Hong Kong, HND1 - Tokyo, Japan, IAD1 - Washington DC, USA, ICN1 - Seoul, South Korea, KIX1 - Osaka, Japan, LHR1 - London, UK, PDX1 - Portland, West US, SFO1 - San Francisco, CA, USA, SIN1 - Singapore, SYD1 - Sydney, Australia).