Elevated TLS handshake times

Incident Report for Vercel

Resolved

This incident has been resolved.
Posted Dec 07, 2023 - 17:47 UTC

Monitoring

We are observing increased latencies in performing TLS handshakes in various edge network regions. The team has identified the root cause and is monitoring the resolution.
Posted Dec 07, 2023 - 17:16 UTC
This incident affected: Edge Network (FRA1 - Frankfurt, Germany, Europe, HKG1 - Hong Kong, IAD1 - Washington DC, USA, ICN1 - Seoul, South Korea, SIN1 - Singapore).