Elevated errors creating deployments with Neon and Supabase integrations

Incident Report for Vercel

Resolved

This incident has been resolved.
Posted Dec 09, 2025 - 05:51 UTC

Update

Deployments using the Supabase integration are now working as expected. We are continuing to work on `Resource provisioning timed out` errors related to the Neon integration.
Posted Dec 09, 2025 - 04:15 UTC

Identified

We've identified a potential root cause in our webhook service affecting the build process. We will continue to provide further updates as we learn more.
Posted Dec 09, 2025 - 03:29 UTC

Investigating

We are currently investigating intermittent `Resource provisioning timed out` errors that occur when creating new deployments with the Neon or Supabase integration. Existing deployments are not affected.
Posted Dec 09, 2025 - 00:31 UTC
This incident affected: Build & Deploy (Builds).